bamajim
Something weird happened.  Last week I tried to log in and got a message; your last e-mail came back marked spam you need to enter a good e-mail address.  Well I have not changed my e-mail address.  After trying several times to log in, I had to delete my account, alabamajim, started a new one as bamajim.  Soooo, I am back and glad to be here.  Still using my same old e-mail address.  
Quote 0
mkevenson
bamajim, welcome back! Now where did you go? We have just been ordered to stay in place, virus thing. Hope you are well.
Mark
Please buy Made in USA
Quote 0
bamajim
mkevenson wrote:
bamajim, welcome back! Now where did you go? We have just been ordered to stay in place, virus thing. Hope you are well.


Well MK it was little like the twilight zone.  I have no idea what happened.  I talked on line with sunvalleyjoe about a month ago, been friends a long time on this forum.  Last week I tried to log on and I puffed away out of no where.  It must have been papa smurph must have been upset.
Quote 0
mkevenson
Joe is a great guy! Next time rub fresh garlic on your feet before posting!!!! Couldn't hurt, except maybe your back.
Mark
Please buy Made in USA
Quote 0
Tiki2some
Lots of email hacking aka "phishing" going on out there: didn't need to be anything you did. Regardless, glad you're back in! Too bad your post history is gone, tho. Reading posts from you, SVJ and Retro195Man were a great help to me when I was shopping for a TT and finally selected Retro. Been very happy with our unit and the travels we've had. So - thanks to all of you!
~ Linda & Bill
Quote 0
mtcyphert
Happy to welcome you back. You have always been the first one to welcome new members.
Quote 0
bamajim
Thanks, I love people and the camping forum.  It feels like and extended family.
Quote 0